icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.syqitao.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

728彩票 www.206897.com-137彩票下载| www.366729.com-彩铅9岁儿童夕阳画| www.25159.com-彩铅怎么水溶| www.73328.com-七星彩明月珰| www.931738.com-双色球彩票必中咒语| 9928彩票www.9928e.com| www.209538.com-彩票规律计算公式| www.562739.com-高频彩有假吗| www.801076.com-购彩软件大全| www.959406.com-河北快三3-| www.cu67.com-开福利彩票店赚钱吗| www.zl56.com-分分彩4期必中| www.50gx.com-烟台福彩招聘信息| www.798589.com-中彩网专家杀号定胆| www.894532.com-内蒙快三每天多少期| www.976380.com-体彩宝石之王中奖率| www.ki1.com-吉林省福利彩票快3| www.uv94.com-吉林快三在哪里开奖| www.26xu.com-体彩大乐透购买中心| www.885768.com-排列三杀号家彩论坛| www.968498.com-彩票作弊最新事件| www.cp4652.com-彩票破解神器手机版| www.om65.com-彩票双色球走试图| www.03tv.com-福彩五分彩怎么玩| www.529190.com-87彩店更新不了| www.633057.com-网上如何买竞彩| www.739668.com-快乐十分彩票网址| www.835373.com-日版好彩香烟好抽吗| www.913073.com-彩托骗局有哪些| www.975780.com-福彩体彩谁中奖率高| www.cp836.com-大发彩票官网| www.ks88.com-彩票销售系统| www.k52.cc-湖北省体彩-| www.916226.com-菠萝彩软件下载安装| www.999915.cc-趣9购彩票是真的吗| www.hk04.com-湖北快三一定牛跨度| www.h07.cn-3d彩宝网试机号| www.325208.com-体彩排三字迷| www.18646.com-长春福彩中心导航| www.188394.com-安徽快三规则| www.289567.com-106官网彩-| www.375844.com-北京彩票店转让协议| www.553792.com-竞彩2串1比赛取消| www.685602.com-下载福利彩票官网| www.773364.com-竟彩心得经验| www.381430.com-买彩票犯法不| www.141615.com-彩票选号器软件下载| www.863319.com-体彩19040-| www.868173.com-七星彩这期规律图| 好彩头彩票www.23579c.com| www.280694.com-机选一注时时彩| www.561059.com-8828彩票网页| www.645722.com-竞彩知识-| www.745658.com-体彩app购彩厅| www.1225.wang-万豪国际博彩邀请码| www.555679.com-体彩牛人票-| www.750046.com-鸿运吧彩票-| www.aa96.com-体彩排列5奖结果| www.101368.com-安微快三计划软件| www.81182.cc-即开彩中奖-| www.031250.com-随机彩票真能中奖吗| www.913.red-彩铅手绘唯美女孩| www.588499.com-七星彩春节放假时间| www.683561.com-义乌开福彩店好批吗| www.135498.com-彩票账对不上| www.079178.com-时时彩高手方法如下| www.361941.com-青蛙彩网-| www.535062.com-6位数买什么彩票| www.684515.com-华彩网是不是骗人的| www.556908.com-永利皇宫网络博彩| www.993924.com-3d彩票怎么玩法| www.52979.cc-时时彩又停了| www.299608.com-陕西体彩爱彩乐| www.465944.com-时时彩对打套利技术| www.622571.com-3d彩报三-| www.750068.com-七星彩精准号码预测| www.933865.com-70彩-| www.de24.com-大乐彩cp-| www.7573.pw-3000万彩票-| www.yl65.cc-万彩吧专家3d预测| www.270042.com-132彩票平台下载| www.712969.com-易彩快3是什么彩票| www.844542.com-福彩业务-| www.913458.com-彩客网提现-| 盈宝彩票www.ybao0.com| www.cp7398.com-今日湖北快三开奖号| www.69315.cc-竞彩网任九开奖| www.03824.com-中国哪些合法彩票| www.030028.com-大發彩-| www.955469.com-苹果彩票手机| www.cai4522.com内蒙古快三预测号码| www.297114.cc-今天福彩3d谜语| www.435209.com-竞彩受注量-| www.345635.com-福彩双色球复式| www.450178.com-爱尚彩彩票-| www.555992.com-彩票模拟试玩网站| www.568492.com-体彩今日断组| www.hb7.com-安徽快三群骗局揭秘| www.766802.com-宁波快三彩票| www.128486.com-708彩票-| www.200072.cc-七乐彩开奖号码表| www.993074.com-三分彩基本走势图| www.k81.org-河北福彩网官网| www.303418.com-优乐彩登录-| www.390088.com-重庆时时彩有漏洞吗| www.459679.com-七星彩中奖号码预则| www.596915.com-幸运赛车是哪里彩票| www.685880.cc-中国福利彩手机下载| www.766908.com-信彩彩票官网首页| www.846550.com-彩票主任悔过| www.907299.com-体彩外围-| www.964078.com-彩吧彩票是什么意思| 500彩票网www.97655q.com| www.599.date-福龙彩票平台| www.92tv.com-五分彩被骗怎么办| www.959891.cc-vr三分彩是什么| 幸运彩票www.852699.com| www.741211.com-体彩电视台开奖时间| www.815572.com-河北省福彩网| www.900614.com-注册就送彩金的网站| www.967535.com-彩票计划群被骗经历| www.zw6.com-588彩票网站| www.058.red-8体彩屋是骗局吗| www.044816.com-彩神v1下载-| www.137844.com-乐彩网首页官网| www.360542.com-快三什么时候停| www.450336.com-福利彩票选法| www.524930.cc-黑客盗取私彩平台钱| www.028675.com-五行数字与彩票3d| www.986476.com-玩彩票平刷能赚钱吗| www.pw78.com-彩票66网-| www.02bq.com-彩迷葫芦弟53期| www.53as.com-家家好彩报纸图| www.500804.com-一寸彩照多久可以拿| www.397472.com-m8彩票官网-| www.500085.com-英国5分彩平台| www.555434.com-c53彩票-| www.609257.com-七星彩19044| www.674710.com-民政部体彩案| www.732923.com-下载江苏体彩七位数| www.789480.com-中国足彩中国足彩网| www.847809.com-彩票怎么挂机比较好| www.895606.com-足彩2串1中一场| www.949702.com-休育彩票开奖| www.985122.com-人福利彩票-| www.cp163.com-新吉林快三走势图| www.490719.com-9购十分彩邀请码| www.697308.com-福彩三d彩吧图库| www.29129.cc-石家庄福彩中心| www.716923.com-儿童彩铅画大全| www.498258.com-京彩中奖信息| www.659666.cc-高频彩怎么开奖的| www.786664.com-花样快三套路教学| www.115496.com-足彩竞彩310| www.87db.com-牛蛙网彩票开奖现场| www.285.cc-民权结婚彩礼| www.397575.com-昆明快三骗人吗| www.099815.com-高频彩害了多少人| www.179257.com-江苏快三能赚钱吗| www.7204.cc-七彩娱乐血战麻将| www.75927.com-彩票作废叫什么| www.791883.com-竞彩足球不能买| www.885893.com-1分快三彩票软件| www.964917.com-电脑福利彩票查询|